summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-24 06:29:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-24 06:34:37 +0100
commit2df984f2787917168afc3eda92817c77dec5bddc (patch)
tree83cb40f558e8520768fc10132b512af55d327ae2
parentcc73339b97901cf1e50f07a6f0114974b34592c4 (diff)
downloadguix-2df984f2787917168afc3eda92817c77dec5bddc.tar.gz
gnu: ir: Use ‘modify-phases’ syntax.
* gnu/packages/audio.scm (ir)[arguments]: Use ‘modify-phases’.
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 492f716ca9..2ecc9a570d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1185,11 +1186,10 @@ well suited to all musical instruments and vocals.")
                "1jh2z01l9m4ar7yz0n911df07dygc7n4cl59p7qdjbh0nvkm747g"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ;no "check" target
+     `(#:tests? #f                              ; no tests
        #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:phases
-       ;; no configure script
-       (alist-delete 'configure %standard-phases)))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))        ; no configure script
     (inputs
      `(("libsndfile" ,libsndfile)
        ("libsamplerate" ,libsamplerate)