summary refs log tree commit diff
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2022-09-30 09:34:39 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-06 23:17:05 +0200
commit37ed844711c1e8c802ea9f7e0f378e6440e4c526 (patch)
treef809377248894a81b3abf5d4fadd428d8b9ef128
parent2a51fb1d29679343dcae508f2d59e90636a5cd7b (diff)
downloadguix-37ed844711c1e8c802ea9f7e0f378e6440e4c526.tar.gz
gnu: squid: Enable TLS features.
Despite openssl being listed as an input, it was not actually enabled by
default.  Fixing that using a configure flag.

* gnu/packages/networking.scm (squid)[arguments]: Add "--with-openssl"
to #:configure-flags.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/networking.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3d9ba4fc8d..3489c3b96a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2010,7 +2010,7 @@ TCP connection, TLS handshake and so on) in the terminal.")
      '(#:configure-flags
        ;; disable -march=native in build for reproducibility; see
        ;; https://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
-       (list "--disable-arch-native")
+       (list "--disable-arch-native" "--with-openssl")
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'fix-true-path