summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2020-11-17 09:52:04 -0600
committerEric Bavier <bavier@member.fsf.org>2020-11-17 09:52:04 -0600
commit3aec121e95581e34a47e3a2d175af97579961206 (patch)
tree2a254279464587d975e0c9a834577e5bc6501b27
parentede4117f7f18e118003f2599f5c8e985dfbdf9a5 (diff)
downloadguix-3aec121e95581e34a47e3a2d175af97579961206.tar.gz
gnu: tomb: Update to 2.8.
Fixes CVE-2020-28638.

* gnu/packages/crypto.scm (tomb): Update to 2.8
[source]: Remove obsolete patch.
* gnu/packages/patches/tomb-fix-errors-on-open.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crypto.scm9
-rw-r--r--gnu/packages/patches/tomb-fix-errors-on-open.patch25
3 files changed, 4 insertions, 31 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d2c3a471e7..d4d10bc32b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1650,7 +1650,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/tk-find-library.patch			\
   %D%/packages/patches/transcode-ffmpeg.patch	\
   %D%/packages/patches/ttf2eot-cstddef.patch			\
-  %D%/packages/patches/tomb-fix-errors-on-open.patch		\
   %D%/packages/patches/tup-unbundle-dependencies.patch		\
   %D%/packages/patches/tuxpaint-stamps-path.patch		\
   %D%/packages/patches/twinkle-bcg729.patch			\
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index aa6f80f731..1b51366d7e 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2017, 2019, 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -444,15 +444,14 @@ total number of shares generated.")
 (define-public tomb
   (package
     (name "tomb")
-    (version "2.7")
+    (version "2.8")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://files.dyne.org/tomb/"
+              (uri (string-append "https://files.dyne.org/tomb/releases/"
                                   "Tomb-" version ".tar.gz"))
               (sha256
                (base32
-                "0x3al02796vx1cvy6y6h685c367qx70dwv471g0hmks2gr10f0cn"))
-              (patches (search-patches "tomb-fix-errors-on-open.patch"))))
+                "0bggzzqmpfiknr76lyl8iszybrcpyqlbgiqk47fxq08h2b5ln1ic"))))
     (build-system gnu-build-system)
     (native-inputs `(("sudo" ,sudo)))   ;presence needed for 'check' phase
     (inputs
diff --git a/gnu/packages/patches/tomb-fix-errors-on-open.patch b/gnu/packages/patches/tomb-fix-errors-on-open.patch
deleted file mode 100644
index 5f41c9ee8f..0000000000
--- a/gnu/packages/patches/tomb-fix-errors-on-open.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: Avoid error messages when opening a new tomb
- Make sure control file exists and has user ownership before user writes to it.
-Author: Sven Geuer <debmaint@g-e-u-e-r.de>
-Bug: https://github.com/dyne/Tomb/issues/369
-Last-Update: 2019-11-04
---- a/tomb
-+++ b/tomb
-@@ -2197,14 +2197,15 @@
- # {{{ Open
- 
- _update_control_file() {
--	# replaces a control file with new contents and gives it user ownership
-+	# make sure a control file exists, gives it user ownership
-+	# and replaces it with new contents
- 	# stdin = contents
- 	# $1 = path to control file
- 	# $2 = contents
- 	[[ "$2" = "" ]] && return 1
- 	_sudo touch "$1"
--	print "$2" > "$1"
- 	_sudo chown ${_UID}:${_GID} "$1"
-+	print "$2" > "$1"
- 	_verbose "updated control file $1 = $2"
- }
-