summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-08 19:04:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 23:01:20 +0200
commit46bb58b8641cb6c9c07a1169e15e2843910297ba (patch)
tree7528b0fc9e55596b18a0ebb3b6edf33b89c715e8
parenta5cdcf6c0986653ebb33fca9227e8a61ce37aed9 (diff)
downloadguix-46bb58b8641cb6c9c07a1169e15e2843910297ba.tar.gz
gnu: Add non-mixer.
* gnu/packages/music.scm (non-mixer): New variable.
-rw-r--r--gnu/packages/music.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3002d27a6e..c05a047615 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -786,6 +786,32 @@ session management.  NSM clients use a well-specified OSC protocol to
 communicate with the session management daemon.")
     (license license:gpl2+)))
 
+(define-public non-mixer
+  (package (inherit non-sequencer)
+    (name "non-mixer")
+    (arguments
+     (substitute-keyword-arguments (package-arguments non-sequencer)
+       ((#:configure-flags flags)
+        `(cons "--project=mixer"
+               (delete "--project=sequencer" ,flags)))))
+    (inputs
+     `(("jack" ,jack-1)
+       ("liblo" ,liblo)
+       ("ladspa" ,ladspa)
+       ("lrdf" ,lrdf)
+       ("ntk" ,ntk)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://non.tuxfamily.org/wiki/Non%20Mixer")
+    (synopsis "Modular digital audio mixer")
+    (description
+     "The Non Mixer is a powerful, reliable and fast modular digital audio
+mixer.  It utilizes JACK for inter-application audio I/O and the NTK GUI
+toolkit for a fast and lightweight user interface.  Non Mixer can be used
+alone or in concert with Non Timeline and Non Sequencer to form a complete
+studio.")
+    (license license:gpl2+)))
+
 (define-public solfege
   (package
     (name "solfege")