summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 12:14:08 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-14 12:16:37 -0400
commit51de28452a9ef2e1fe7393ee49daeb87866541ba (patch)
tree79fcad517203af3ac28ce3ded9f39779b0c71d9d
parent66f0304e1de40bdc39ba2abc515e2cf8433c8f93 (diff)
downloadguix-51de28452a9ef2e1fe7393ee49daeb87866541ba.tar.gz
gnu: Add python-makefun.
* gnu/packages/python-xyz.scm (python-makefun): New variable.

Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 069d60fdda..8cdb3a08bc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -61,7 +61,7 @@
 ;;; Copyright © 2019, 2023 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2019-2023, Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2019, 2020, 2021, 2022 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019, 2020, 2021, 2022, 2023 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2019, 2020, 2021 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
@@ -5272,6 +5272,26 @@ recognition library with full Unicode support.  It has features like:
 @end itemize")
     (license license:expat)))
 
+(define-public python-makefun
+  (package
+    (name "python-makefun")
+    (version "1.15.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "makefun" version))
+              (sha256
+               (base32
+                "19a8dga8rnmjn5gy1cy1wdi28swbkdkypwbqikbxil6ynqcg3c20"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-pytest python-setuptools-scm))
+    (home-page "https://github.com/smarie/python-makefun")
+    (synopsis "Library to dynamically create python functions")
+    (description "@code{makefun} helps create functions dynamically with a
+given signature.  It was largely inspired by @code{python-decorator} and
+@code{functools}.")
+    (license license:bsd-3)))
+
 (define-public python-markdown-it-py
   (package
     (name "python-markdown-it-py")