summary refs log tree commit diff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-10-12 03:50:03 +0000
committerLudovic Courtès <ludo@gnu.org>2020-10-27 18:00:28 +0100
commit560eec4010f6302e2e3ec270536646ca0e12436c (patch)
tree8396c466deee363f1d50c812c8dcbaffb5ba287e
parent9b390921b41b1de12d80e0a8c531010294fd05f7 (diff)
downloadguix-560eec4010f6302e2e3ec270536646ca0e12436c.tar.gz
gnu: Add go-golang-org-x-xerrors.
* gnu/packages/golang.scm (go-golang-org-x-xerrors): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b60f18b04..648e8cfba4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -912,6 +912,30 @@ time.")
  spec in Go.")
       (license license:bsd-3))))
 
+(define-public go-golang-org-x-xerrors
+  (let ((commit "5ec99f83aff198f5fbd629d6c8d8eb38a04218ca")
+        (revision "0"))
+    (package
+      (name "go-golang-org-x-xerrors")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://go.googlesource.com/xerrors")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1dbzc3gmf2haazpv7cgmv97rq40g2xzwbglc17vas8dwhgwgwrzb"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "golang.org/x/xerrors"))
+      (synopsis "Go 1.13 error values")
+      (description
+       "This package holds the transition packages for the new Go 1.13 error values.")
+      (home-page "https://godoc.org/golang.org/x/xerrors")
+      (license license:bsd-3))))
+
 (define-public go-github-com-burntsushi-toml
   (package
     (name "go-github-com-burntsushi-toml")