summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-11 21:02:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-11 21:56:39 +0100
commit59adc621affeaadf1ff54508091a11f91704056b (patch)
tree7d9b3672543b5864039b12af5d65a861e227655f
parenteccb1e0964e8e93a07b885c3a64033306735d179 (diff)
downloadguix-59adc621affeaadf1ff54508091a11f91704056b.tar.gz
gnu: crawl: Update to 0.28.0.
* gnu/packages/games.scm (crawl): Update to 0.28.0.
[inputs]: Add BASH-MINIMAL.
* gnu/packages/patches/crawl-upgrade-saves.patch: Update for 0.28.
-rw-r--r--gnu/packages/games.scm7
-rw-r--r--gnu/packages/patches/crawl-upgrade-saves.patch14
2 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9a669621dd..06feb897eb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6390,14 +6390,14 @@ fish.  The whole game is accompanied by quiet, comforting music.")
 (define-public crawl
   (package
     (name "crawl")
-    (version "0.27.1")
+    (version "0.28.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/crawl/crawl/releases/download/"
                            version "/stone_soup-" version "-nodeps.tar.xz"))
        (sha256
-        (base32 "0nkhyhrrma8gmwxp15j84cn1k2yvyq7ar9rd0j2qjjlv2kdis5z2"))
+        (base32 "0irg5w4m127fxcj037kyp9vnyqyq1fi4q64rn6yq92w8z1lf2sss"))
        (patches (search-patches "crawl-upgrade-saves.patch"))))
     (build-system gnu-build-system)
     (inputs
@@ -6406,7 +6406,8 @@ fish.  The whole game is accompanied by quiet, comforting music.")
        ("sqlite" ,sqlite)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("bison" ,bison)
+     `(("bash" ,bash-minimal)
+       ("bison" ,bison)
        ("flex" ,flex)
        ("perl" ,perl)
        ("python" ,python-wrapper)
diff --git a/gnu/packages/patches/crawl-upgrade-saves.patch b/gnu/packages/patches/crawl-upgrade-saves.patch
index 4c0b3a427b..720a94f3e5 100644
--- a/gnu/packages/patches/crawl-upgrade-saves.patch
+++ b/gnu/packages/patches/crawl-upgrade-saves.patch
@@ -8,15 +8,15 @@ and crawl would never upgrade saves.
 diff -ur a/source/database.cc b/source/database.cc
 --- a/source/database.cc	2018-08-09 21:49:26.000000000 -0400
 +++ b/source/database.cc	2018-10-07 18:06:41.022445789 -0400
-@@ -25,6 +25,7 @@
+@@ -24,6 +24,7 @@
+ #include "stringutil.h"
  #include "syscalls.h"
- #include "threads.h"
  #include "unicode.h"
 +#include "version.h"
  
  // TextDB handles dependency checking the db vs text files, creating the
  // db, loading, and destroying the DB.
-@@ -55,6 +56,7 @@
+@@ -54,6 +55,7 @@
      vector<string> _input_files;
      DBM* _db;
      string timestamp;
@@ -62,16 +62,16 @@ diff -ur a/source/database.cc b/source/database.cc
      for (const string &file : _input_files)
      {
          string full_input_path = _directory + file;
-@@ -245,7 +253,7 @@
+@@ -246,7 +254,7 @@
          ts += buf;
      }
  
--    if (no_files && timestamp.empty())
-+    if (no_files && timestamp.empty() && version.empty())
+-    if (no_files)
++    if (no_files && version.empty())
      {
          // No point in empty databases, although for simplicity keep ones
          // for disappeared translations for now.
-@@ -313,7 +321,10 @@
+@@ -312,7 +320,10 @@
              _store_text_db(full_input_path, _db);
          }
      }