summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 12:13:18 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:36 +0100
commit5bc1efd77dad5dde6bd353a9d29d41d48d83ed55 (patch)
tree55d4764bf9a4dbf1e1dde4c35da31aae0236ccba
parentfa274ab2c0121e0d46c10cc2a56390ec3c463747 (diff)
downloadguix-5bc1efd77dad5dde6bd353a9d29d41d48d83ed55.tar.gz
gnu: kdelibs4support: Make test kstandarddirstest pass.
* gnu/package/kde-frameworks.scm(kdelibs4support)[#:phases]
  <check-post-install>: Add workaround for bug in test-case.
  Update comment.
-rw-r--r--gnu/packages/kde-frameworks.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index efd78766a5..6f261afd1a 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3343,8 +3343,11 @@ workspace.")
              ;; enable debug output
              (setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; enable debug output
              (setenv "DBUS_FATAL_WARNINGS" "0")
-             ;; TODO: Make this tests pass (also see
-             ;; https://bugs.kde.org/381098)
+             ;; Make kstandarddirstest pass (see https://bugs.kde.org/381098)
+             (mkdir-p ".kde-unit-test/xdg/config")
+             (with-output-to-file ".kde-unit-test/xdg/config/foorc"
+               (lambda () #t))  ;; simply touch the file
+             ;; kuniqueapptest hangs. TODO: Make this test pass.
              (zero? (system* "dbus-launch" "ctest" "."
                              "-E" "kstandarddirstest|kuniqueapptest")))))))
     (home-page "https://community.kde.org/Frameworks")