summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-10-09 17:08:44 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-10-10 21:33:23 +0200
commit655b227c2b7f84950dbdc6791e61358bed35831b (patch)
treeb2edcab0a00e255b66ff00d835d1e2b65354816c
parentc6318c84340bedafb6ba4ae23a0312b7ba0442c3 (diff)
downloadguix-655b227c2b7f84950dbdc6791e61358bed35831b.tar.gz
gnu: gegl: Enable GIR.
* gnu/packages/gimp.scm (gegl)[arguments]<#:configure-flags>: Remove.
[native-inputs]: Sort alphabetically. Add gobject-introspection, vala.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gimp.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index d69425fde9..5e46eb36b7 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -227,8 +227,6 @@ provided, as well as a framework to add new color models and data types.")
     (build-system meson-build-system)
     (arguments
      `(#:meson ,meson-0.55
-       #:configure-flags
-       (list "-Dintrospection=false")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'extend-test-time-outs
@@ -254,9 +252,11 @@ provided, as well as a framework to add new color models and data types.")
        ("libpng" ,libpng)
        ("libjpeg" ,libjpeg-turbo)))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("glib" ,glib "bin")             ; for gtester
-       ("intltool" ,intltool)))
+     `(("glib" ,glib "bin")             ; for gtester
+       ("gobject-introspection" ,gobject-introspection)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
     (home-page "https://gegl.org")
     (synopsis "Graph based image processing framework")
     (description "GEGL (Generic Graphics Library) provides infrastructure to