summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-12 22:40:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 22:40:18 +0200
commit662e2e82b1b32b98077ffbf35cf2a6985a2c75e3 (patch)
tree30b03a7de5a6f6cac6444d7d67898827892a8e54
parent001d9b1c64dd7274044f4168272146883f34201b (diff)
downloadguix-662e2e82b1b32b98077ffbf35cf2a6985a2c75e3.tar.gz
gnu: arriba: Use SEARCH-INPUT-FILE and -DIRECTORY.
* gnu/packages/bioinformatics.scm (arriba)[arguments]:
Use SEARCH-INPUT-DIRECTORY and SEARCH-INPUT-FILE; use G-expression; drop
trailing #T from build phases.
-rw-r--r--gnu/packages/bioinformatics.scm59
1 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6d34c0abab..0bdec29807 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16525,35 +16525,36 @@ includes a command line tool and an analysis pipeline.")
          "0jx9656ry766vb8z08m1c3im87b0c82qpnjby9wz4kcz8vn87dx2"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; there are none
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((htslib (assoc-ref inputs "htslib")))
-               (substitute* "Makefile"
-                 (("-I\\$\\(HTSLIB\\)/htslib")
-                  (string-append "-I" htslib "/include/htslib"))
-                 ((" \\$\\(HTSLIB\\)/libhts.a")
-                  (string-append " " htslib "/lib/libhts.so"))))
-             (substitute* "run_arriba.sh"
-               (("^STAR ") (string-append (which "STAR") " "))
-               (("samtools --version-only")
-                (string-append (which "samtools") " --version-only"))
-               (("samtools index")
-                (string-append (which "samtools") " index"))
-               (("samtools sort")
-                (string-append (which "samtools") " sort")))
-             #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-               (install-file "arriba" bin)
-               (install-file "run_arriba.sh" bin)
-               (install-file "draw_fusions.R" bin)
-               (wrap-program (string-append bin "/draw_fusions.R")
-                 `("R_LIBS_SITE" ":" prefix (,(getenv "R_LIBS_SITE")))))
-             #t)))))
+     (list
+      #:tests? #f                       ;there are none
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "Makefile"
+                (("-I\\$\\(HTSLIB\\)/htslib")
+                 (string-append "-I"
+                                (search-input-directory inputs "/include/htslib")))
+                ((" \\$\\(HTSLIB\\)/libhts.a")
+                 (string-append " " (search-input-file inputs "/lib/libhts.so"))))
+              (let ((samtools (search-input-file inputs "/bin/samtools")))
+                (substitute* "run_arriba.sh"
+                  (("^STAR ")
+                   (string-append (search-input-file inputs "/bin/STAR") " "))
+                  (("samtools --version-only")
+                   (string-append samtools " --version-only"))
+                  (("samtools index")
+                   (string-append samtools " index"))
+                  (("samtools sort")
+                   (string-append samtools " sort"))))))
+          (replace 'install
+            (lambda _
+              (let ((bin (string-append #$output "/bin")))
+                (install-file "arriba" bin)
+                (install-file "run_arriba.sh" bin)
+                (install-file "draw_fusions.R" bin)
+                (wrap-program (string-append bin "/draw_fusions.R")
+                  `("R_LIBS_SITE" ":" prefix (,(getenv "R_LIBS_SITE"))))))))))
     (inputs
      (list htslib
            r-minimal