summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-19 12:29:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-19 12:38:41 +0300
commit66a3c2db9b1d344145ded88fd5aeec4cff77137f (patch)
treea1dcd3ba27c0378dad6476f0577260a781c88d6e
parent5d484f42a87d7121b6f9d50bb5f8d61e157bb186 (diff)
downloadguix-66a3c2db9b1d344145ded88fd5aeec4cff77137f.tar.gz
gnu: python2-matplotlib: Fix jquery-ui install path.
* gnu/packages/python-xyz.scm (python2-matplotlib)[arguments]: Override
custom 'install-jquery-ui phase to install in the appropriate directory.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66f7e176e2..71adf82a77 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3941,6 +3941,16 @@ toolkits.")
        (substitute-keyword-arguments (package-arguments matplotlib)
          ((#:phases phases)
           `(modify-phases ,phases
+             (replace 'install-jquery-ui
+               (lambda* (#:key outputs inputs #:allow-other-keys)
+                 (let ((dir (string-append (assoc-ref outputs "out")
+                                           "/lib/python2.7/site-packages/"
+                                           "matplotlib/backends/web_backend/")))
+                   (mkdir-p dir)
+                   (invoke "unzip"
+                           (assoc-ref inputs "jquery-ui")
+                           "-d" dir))
+                 #t))
              (delete 'check))))) ; These tests weren't run the the past.
       ;; Make sure to use special packages for Python 2 instead
       ;; of those automatically rewritten by package-with-python2.