summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-01-12 20:33:46 +0100
committerJohn Darrington <jmd@gnu.org>2017-01-12 21:11:26 +0100
commit6ea1523ac8033c7eb353c51bef654e6934a115ec (patch)
treeef55848fd036732108725571bdf71f28263f8925
parentf50fff693bdfbb71fea7ac9ee7dcef0eb9fb77bc (diff)
downloadguix-6ea1523ac8033c7eb353c51bef654e6934a115ec.tar.gz
gnu: Add xmag.
* gnu/packages/xorg.scm (xmag): New variable.
-rw-r--r--gnu/packages/xorg.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ac35a8c179..fbea7072b3 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5594,6 +5594,35 @@ user-friendly mechanism to start the X server.")
 Intrinsics (Xt) Library.")
     (license license:x11)))
 
+(define-public xmag
+  (package
+    (name "xmag")
+    (version "1.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://xorg/individual/app/" name "-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "19bsg5ykal458d52v0rvdx49v54vwxwqg8q36fdcsv9p2j8yri87"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-appdefaultdir="
+                            %output ,%app-defaults-dir))))
+    (inputs
+     `(("libxaw" ,libxaw)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://www.x.org/wiki/")
+    (synopsis "Display or capture a magnified part of a X11 screen")
+    (description "Xmag displays and captures a magnified snapshot of a portion
+of an X11 screen.")
+    (license license:x11)))
+
 (define-public xmessage
   (package
     (name "xmessage")