summary refs log tree commit diff
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:08 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:54 +0200
commit796045b2c2989761be2122f24528853171d58110 (patch)
tree60a6967995fef8fced45fb397e156554aadde015
parent1e0e94c35e5f0d803f5ef2119338fbe0370f978d (diff)
downloadguix-796045b2c2989761be2122f24528853171d58110.tar.gz
gnu: Add elm-explorations-markdown.
* gnu/packages/elm.scm (elm-explorations-markdown): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/elm.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 48594613f3..8f92eea041 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -397,3 +397,22 @@ you.")
     (properties '((upstream-name . "elm/project-metadata-utils")))
     (license license:bsd-3)))
 
+(define-public elm-explorations-markdown
+  (package
+    (name "elm-explorations-markdown")
+    (version "1.0.0")
+    (source
+     (elm-package-origin
+      "elm-explorations/markdown"
+      version
+      (base32 "1f57ikdpbbhchcpwj32216gxjxijrc3sdpg27s1cgzia9pnkqk6p")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-html elm-core))
+    (home-page
+     "https://package.elm-lang.org/packages/elm-explorations/markdown/1.0.0")
+    (synopsis "Fast markdown parsing and rendering in Elm")
+    (description
+     "This package is for markdown parsing and rendering in Elm.  It is based
+on the @code{marked} project, which focuses on speed.")
+    (license license:bsd-3)))
+