summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 18:24:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:16 +0200
commit7c3d479e831e9d13752a237ca63aae5cc04ce70d (patch)
treeefaa637fbd001622a78b1be24722606eebbbff28
parente8d0f7c8f9913218452e65d6f891af5773aee38a (diff)
downloadguix-7c3d479e831e9d13752a237ca63aae5cc04ce70d.tar.gz
gnu: Add java-eclipse-ant-core.
* gnu/packages/java.scm (java-eclipse-ant-core): New variable.
-rw-r--r--gnu/packages/java.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 37a6a04f84..b8ab673d18 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2671,6 +2671,38 @@ with the @code{org.eclipse.core.expressions} module.")
 @code{org.eclipse.core.variables}.")
     (license license:epl1.0)))
 
+(define-public java-eclipse-ant-core
+  (package
+    (name "java-eclipse-ant-core")
+    (version "3.4.100")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/eclipse/platform/org.eclipse.ant.core/"
+                                  version "/org.eclipse.ant.core-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "11g3if794qjlk98mz9zch22rr56sd7z63vn4i7k2icr8cq5bfqg7"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:jar-name "eclipse-ant-core.jar"))
+    (inputs
+     `(("java-eclipse-equinox-app" ,java-eclipse-equinox-app)
+       ("java-eclipse-equinox-common" ,java-eclipse-equinox-common)
+       ("java-eclipse-equinox-registry" ,java-eclipse-equinox-registry)
+       ("java-eclipse-equinox-preferences" ,java-eclipse-equinox-preferences)
+       ("java-eclipse-core-contenttype" ,java-eclipse-core-contenttype)
+       ("java-eclipse-core-runtime" ,java-eclipse-core-runtime)
+       ("java-eclipse-core-variables" ,java-eclipse-core-variables)
+       ("java-eclipse-osgi" ,java-eclipse-osgi)))
+    (home-page "https://www.eclipse.org/platform")
+    (synopsis "Ant build tool core libraries")
+    (description "This package provides the ant build tool core libraries with
+the module @code{org.eclipse.ant.core}.")
+    (license license:epl1.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")