summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-10-28 11:33:20 +0900
committerMathieu Othacehe <m.othacehe@gmail.com>2018-11-07 18:39:19 +0900
commit8243f4e55a9f87821370eb2198fa9b5c8eac6648 (patch)
tree29f8e767bb71adac5156e4b0646611bc6794d7eb
parenta7903ca1500e2385bc26db5e8a139539c0c2294c (diff)
downloadguix-8243f4e55a9f87821370eb2198fa9b5c8eac6648.tar.gz
gnu: slang: Use a correct location for terminfo dirs.
As termcap is disabled and no terminfo directory is given, slang is not able
to query terminal capabilities. Specifying a correct path for terminfo will
automatically disable termcap support in the configuration.

* gnu/packages/slang.scm (slang)[source]: Remove the snippet disabling
termcap.
[arguments]: Set MISC_TERMINFO_DIRS to a correct location.
-rw-r--r--gnu/packages/slang.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/slang.scm b/gnu/packages/slang.scm
index 24eb5fa137..185d441919 100644
--- a/gnu/packages/slang.scm
+++ b/gnu/packages/slang.scm
@@ -50,13 +50,21 @@
                '(begin
                   (substitute* "src/Makefile.in"
                     (("/bin/ln") "ln"))
-                  (substitute* "configure"
-                    (("-ltermcap") ""))
                   #t))))
     (build-system gnu-build-system)
     (arguments
      '(#:parallel-tests? #f
-       #:parallel-build? #f)) ; there's at least one race
+       #:parallel-build? #f  ; there's at least one race
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'substitute-before-config
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((ncurses (assoc-ref inputs "ncurses")))
+               (substitute* "configure"
+                 (("MISC_TERMINFO_DIRS=\"\"")
+                  (string-append "MISC_TERMINFO_DIRS="
+                                 "\"" ncurses "/share/terminfo" "\"")))
+               #t))))))
     (inputs
      `(("readline" ,readline)
        ("zlib" ,zlib)