summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-05 01:47:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commit8caab758834cc6e6c3c664e7c7cb138662413fb0 (patch)
tree65692bb5f7d67d5cba65080753fa418c0a333950
parentab4a91b25280f4e57f007e5b3cea72a30091f647 (diff)
downloadguix-8caab758834cc6e6c3c664e7c7cb138662413fb0.tar.gz
gnu: Add r-ggtree.
* gnu/packages/bioconductor.scm (r-ggtree): New variable.
-rw-r--r--gnu/packages/bioconductor.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 10463b29c2..d779a11643 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5707,6 +5707,42 @@ heterogeneous associated data to a single tree file and can be served as a
 platform for merging tree with associated data and converting file formats.")
     (license license:artistic2.0)))
 
+(define-public r-ggtree
+  (package
+    (name "r-ggtree")
+    (version "3.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ggtree" version))
+       (sha256
+        (base32
+         "0i665b5jxgsv3ncxmczy7n0h911br44dw9f7m4jwv3pjmr5mm6vk"))))
+    (properties `((upstream-name . "ggtree")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ape" ,r-ape)
+       ("r-aplot" ,r-aplot)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-magrittr" ,r-magrittr)
+       ("r-purrr" ,r-purrr)
+       ("r-rlang" ,r-rlang)
+       ("r-rvcheck" ,r-rvcheck)
+       ("r-scales" ,r-scales)
+       ("r-tidyr" ,r-tidyr)
+       ("r-tidytree" ,r-tidytree)
+       ("r-treeio" ,r-treeio)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://yulab-smu.top/treedata-book/")
+    (synopsis "R package for visualization of trees and annotation data")
+    (description
+     "This package extends the ggplot2 plotting system which implements a
+grammar of graphics.  ggtree is designed for visualization and annotation of
+phylogenetic trees and other tree-like structures with their annotation
+data.")
+    (license license:artistic2.0)))
+
 (define-public r-biocsingular
   (package
     (name "r-biocsingular")