summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-16 11:16:31 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 14:46:53 -0500
commit9582f49a0c9063f3668ff3d16fd4c1a5ee8071eb (patch)
treef8f53aa4d62e42d22eecc08c77248005096ab7d6
parent5219284621f438cbb1ef0f7c62882f6e7cd473f9 (diff)
downloadguix-9582f49a0c9063f3668ff3d16fd4c1a5ee8071eb.tar.gz
gnu: phodav: Propagate glib, libsoup and libxml2.
* gnu/packages/gnome.scm (phodav) [inputs]: Move libsoup to...
[propagated-inputs]: ... here.  Add glib and libxml2.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b290a93723..9ffbce2df3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1268,8 +1268,12 @@ Library reference documentation.")
            pkg-config))
     (inputs
      (list avahi
-           libgudev
-           libsoup))
+           libgudev))
+    (propagated-inputs
+     ;; These inputs are required by the pkg-config file.
+     (list glib
+           libsoup
+           libxml2))
     (synopsis "WebDav server implementation using libsoup")
     (description "PhoDav was initially developed as a file-sharing mechanism for Spice,
 but it is generic enough to be reused in other projects,