summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-05-11 18:30:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-12 09:36:26 +0200
commit9d05f9a9f538061e1fdc5aedb0748d260fcf20f7 (patch)
tree53a9be0d50867e17ef87f420539306656e4fb7d8
parenta5bae9c7486b88c6b416cbd74dc0c7990fb10f73 (diff)
downloadguix-9d05f9a9f538061e1fdc5aedb0748d260fcf20f7.tar.gz
gnu: Add r-dropletutils.
* gnu/packages/bioconductor.scm (r-dropletutils): New variable.
-rw-r--r--gnu/packages/bioconductor.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index cb441655eb..265a70cdd4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4897,6 +4897,50 @@ makes available functions for visualization and exploration of the data and
 results.")
     (license license:gpl3+)))
 
+(define-public r-dropletutils
+  (package
+    (name "r-dropletutils")
+    (version "1.20.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "DropletUtils" version))
+       (sha256
+        (base32 "09xwfb4ihpsp465vb1zbcwm6ww6qi3spn9d8p4i1gczyc0p9pf1y"))))
+    (properties `((upstream-name . "DropletUtils")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-beachmat
+           r-bh
+           r-biocgenerics
+           r-biocparallel
+           r-delayedarray
+           r-delayedmatrixstats
+           r-dqrng
+           r-edger
+           r-genomicranges
+           r-hdf5array
+           r-iranges
+           r-matrix
+           r-r-utils
+           r-rcpp
+           r-rhdf5
+           r-rhdf5lib
+           r-s4vectors
+           r-scuttle
+           r-singlecellexperiment
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/DropletUtils")
+    (synopsis "Utilities for handling single-cell droplet data")
+    (description
+     "This package provides a number of utility functions for handling
+single-cell RNA-seq data from droplet technologies such as 10X Genomics.  This
+includes data loading from count matrices or molecule information files,
+identification of cells from empty droplets, removal of barcode-swapped
+pseudo-cells, and downsampling of the count matrix.")
+    (license license:gpl3)))
+
 (define-public r-dss
   (package
     (name "r-dss")