summary refs log tree commit diff
diff options
context:
space:
mode:
authorHunter Jozwiak <hunter.t.joz@gmail.com>2022-10-10 07:02:18 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-09 02:00:10 +0200
commita86979b41a49a8fcdaa887970ba594dbba701226 (patch)
treee4f5b4dd80ee2c8df8f7f3b5e1e8d5e131766037
parentf2af4ca71f16a5a08defaecc06d7ea4be1325d1c (diff)
downloadguix-a86979b41a49a8fcdaa887970ba594dbba701226.tar.gz
gnu: linux-libre: Enable accessibility features.
* gnu/packages/linux.scm (%default-extra-linux-options): Enable
speakup and Braille console options by default.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 850a136ce2..aa7475a2f5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -65,6 +65,7 @@
 ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
 
 ;;;
 ;;; This file is part of GNU Guix.
@@ -700,6 +701,11 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
     ("CONFIG_ZSWAP" . #t)
     ("CONFIG_ZSMALLOC" . #t)
     ("CONFIG_ZRAM" . m)
+    ;; Accessibility support.
+    ("CONFIG_ACCESSIBILITY" . #t)
+    ("CONFIG_A11Y_BRAILLE_CONSOLE" . #t)
+    ("CONFIG_SPEAKUP" . m)
+    ("CONFIG_SPEAKUP_SYNTH_SOFT" . m)
     ;; Modules required for initrd:
     ("CONFIG_NET_9P" . m)
     ("CONFIG_NET_9P_VIRTIO" . m)