summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-18 11:08:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-18 11:23:47 -0400
commita8e17eb8e53b58e2298217f092e60e79d63a40dd (patch)
tree16097c4efae7bf322e0a23b89c4ad5ccac1e7b54
parent813d670b151b06181fd045d6e00104f3da63f4a0 (diff)
downloadguix-a8e17eb8e53b58e2298217f092e60e79d63a40dd.tar.gz
gnu: samba: Apply graft, and make graft private.
* gnu/packages/samba.scm (samba) [replacement]: Add field.
(samba/security-fixes): Renamed from samba/fixed, for clarity.
* gnu/packages/samba.scm (samba/pinned): Adjust for graft variable name change.
-rw-r--r--gnu/packages/samba.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index e09acf49f9..57562b3b7a 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -172,6 +172,7 @@ external dependencies.")
 (define-public samba
   (package
     (name "samba")
+    (replacement samba/security-fixes)
     (version "4.16.8")
     (source
      ;; For updaters: the current PGP fingerprint is
@@ -294,7 +295,7 @@ Desktops into Active Directory environments using the winbind daemon.")
   (hidden-package
    (package
      (inherit samba)
-     (replacement samba/fixed)
+     (replacement samba/security-fixes)
      (version "4.15.3")
      (source
       (origin
@@ -329,7 +330,7 @@ Desktops into Active Directory environments using the winbind daemon.")
              libxml2))))))              ;for XML_CATALOG_FILES
 
 
-(define-public samba/fixed
+(define samba/security-fixes
   (package
     (inherit samba/pinned)
     ;; This is 4.15.13, but we need to trim the store file name to have