summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 13:02:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 13:02:16 +0200
commitaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (patch)
treedb507bd1bb496b119e701c8979e4cbcabf5c1af3
parent95d5090d9c9df7759ab053a896fb4cfa2037c77b (diff)
downloadguix-aba40a6b7fdce56fe439668b3152ae4d4ddd1551.tar.gz
gnu: python-urwid: Remove sporadically failing tests.
* gnu/packages/python-xyz.scm (python-urwid)[arguments]: Add phase to
remove problematic test.
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f89075a045..4afd9a2c86 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8701,6 +8701,15 @@ computing.")
         (base32
          "1bky2bra6673xx8jy0826znw6cmxs89wcwwzda8d025j3jffx2sq"))))
     (build-system python-build-system)
+    (arguments
+      (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'remove-vterm-tests
+              ;; According to Debian these tests are cursed.
+              ;; https://salsa.debian.org/python-team/packages/urwid/-/blob/debian/2.1.2-2/debian/changelog#L141
+              (lambda _
+                (delete-file "urwid/tests/test_vterm.py"))))))
     (home-page "http://urwid.org")
     (synopsis "Console user interface library for Python")
     (description