summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-09-11 08:46:34 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-11 11:20:09 +0200
commitabe4bdad800589a84d75903d5b85a1d798a6924a (patch)
treeef45000b9b464bca79fb63347ad573859a020307
parent856591e2b50cb5f186f01b252be239ae7553eeef (diff)
downloadguix-abe4bdad800589a84d75903d5b85a1d798a6924a.tar.gz
gnu: psm: Fix building with GCC 10.
I had to copy all the CFLAGS that were originally defined by the
Makefile as they were otherwise all replaced by '-fcommon'.

* gnu/packages/linux.scm (psm)[arguments]: Pass '-fcommon' to CFLAGS.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1305a80f56..122c2773fb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -56,6 +56,7 @@
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7256,6 +7257,11 @@ libraries, which are often integrated directly into libfabric.")
     (arguments
      '(#:make-flags `("PSM_USE_SYS_UUID=1" "CC=gcc" "WERROR="
                       ,(string-append "INSTALL_PREFIX=" %output)
+                      ,(string-append "CFLAGS=-Wall -fpic -fPIC -D_GNU_SOURCE"
+                                      " -funwind-tables -O3 -g3"
+                                      " -DPSM_USE_SYS_UUID"
+                                      " -Wno-strict-aliasing -DNVALGRIND"
+                                      " -fcommon")
                       ,(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
        #:tests? #f
        #:phases (modify-phases %standard-phases