summary refs log tree commit diff
diff options
context:
space:
mode:
authoraecepoglu <aecepoglu@fastmail.fm>2021-02-04 14:38:02 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-04 15:48:30 +0100
commitaccdd71483497257954f9df5c687046c0624ce6d (patch)
tree75865aeb0405b44d43b88542b707208a8cf88533
parentc844ab8653d607a58fb6973eb3a1e93249f572cc (diff)
downloadguix-accdd71483497257954f9df5c687046c0624ce6d.tar.gz
gnu: Add rust-ropey-1.
* gnu/packages/crates-io.scm (rust-ropey-1): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dfd0543806..c7757bc7b7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28922,6 +28922,35 @@ Rust Language Server.")
        (;("rust-serde-bytes" ,rust-serde-bytes-0.10)
         ("rust-serde-json" ,rust-serde-json-1))))))
 
+(define-public rust-ropey-1
+  (package
+    (name "rust-ropey")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ropey" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "10qsj7m6hz953ar68q7iqwwizrh89jaclgffzglb7nwzb0bfzwzh"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-smallvec" ,rust-smallvec-1))
+       #:cargo-development-inputs
+       (("rust-bencher" ,rust-bencher-0.1)
+        ("rust-proptest" ,rust-proptest-0.9)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-unicode-segmentation" ,rust-unicode-segmentation-1))))
+    (home-page "https://github.com/cessen/ropey")
+    (synopsis "Fast and robust text rope for Rust")
+    (description
+     "Ropey is a UTF-8 text rope for Rust, designed to be the backing
+text-buffer for applications such as text editors.  Ropey is fast, robust, and
+can handle huge texts and memory-incoherent edits with ease.")
+    (license license:expat)))
+
 (define-public rust-route-recognizer-0.2
   (package
     (name "rust-route-recognizer")