summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-09 02:00:03 +0200
commitb0e5576702057ed2fb4898f07b655a55789484a3 (patch)
treee40d6c798df18478181a467dbcec5276ee0fe1ac
parent57995527394a04abc48bf89b9678cc35a9836662 (diff)
downloadguix-b0e5576702057ed2fb4898f07b655a55789484a3.tar.gz
gnu: anthy: Add source mirror URL.
* gnu/packages/anthy.scm (anthy)[source]: Add a Japanese Gentoo
distfiles mirror.
-rw-r--r--gnu/packages/anthy.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/anthy.scm b/gnu/packages/anthy.scm
index 0d86347e88..4a0066a621 100644
--- a/gnu/packages/anthy.scm
+++ b/gnu/packages/anthy.scm
@@ -27,15 +27,17 @@
   (package
     (name "anthy")
     (version "9100h")
-    (source (origin
-              (method url-fetch)
-              ;; The URI does not appear to be easily guessable.  For
-              ;; example, you cannot download version "9100g" simply
-              ;; by replacing "9100h" in the URI.
-              (uri "http://dl.osdn.jp/anthy/37536/anthy-9100h.tar.gz")
-              (sha256
-               (base32
-                "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
+    (source
+     (origin
+       (method url-fetch)
+       ;; The URI does not appear to be easily guessable.  For
+       ;; example, you cannot download version "9100g" simply
+       ;; by replacing "9100h" in the URI.
+       (uri (list (string-append "https://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
+                                 "distfiles/31/anthy-9100h.tar.gz")
+                  "https://osdn.dl.osdn.net/anthy/37536/anthy-9100h.tar.gz"))
+       (sha256
+        (base32 "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
     (build-system gnu-build-system)
     ;; Anthy also contains elisp modules for using anthy within Emacs.
     ;; However, these modules are incompatible with the latest version