summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom Bologov <mail@aartaka.me>2023-07-14 18:09:12 +0400
committerGuillaume Le Vaillant <glv@posteo.net>2023-07-15 10:56:46 +0200
commitb5a5e4d712d0a1998995be62bb41b03955b7dcf1 (patch)
tree0b344a1c86c203e2c33d7c0f393b6c6d8323b40b
parent5dc2a88f99e2e448f7e9ca842a4a0d072a8f8f20 (diff)
downloadguix-b5a5e4d712d0a1998995be62bb41b03955b7dcf1.tar.gz
gnu: cl-nhooks: Update to 1.2.1.
* gnu/packages/lisp-xyz.scm (sbcl-nhooks): Update to 1.2.1.
  [native-inputs]: Remove sbcl-fiveam, add sbcl-lisp-unit2.

Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index a59c555f9a..9fc5341521 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -25508,22 +25508,22 @@ JavaScript code.")
 (define-public sbcl-nhooks
   (package
     (name "sbcl-nhooks")
-    (version "1.2.0")
+    (version "1.2.1")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/atlas-engineer/nhooks")
              (commit version)))
-       (file-name (git-file-name "nhooks" version))
+       (file-name (git-file-name "cl-nhooks" version))
        (sha256
         (base32
-         "1cpd9ydxkrl4vxn2clfwljl4q5hdybxkc96qshq7dczq2jvg1nfs"))))
+         "10ym4ybda2l426flicqz0f4yg7fbw7yjk1k0wqpf4wfk24gm1b8g"))))
     (build-system asdf-build-system/sbcl)
     (inputs
      (list sbcl-serapeum))
     (native-inputs
-     (list sbcl-fiveam))
+     (list sbcl-lisp-unit2))
     (home-page "https://github.com/atlas-engineer/nhooks")
     (synopsis "Hook facility for Common Lisp")
     (description "This package holds an enhanced implementation of