summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 18:56:05 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:16 +0100
commitbe398aa2b4ed24e73cb2d6865a2040bb12eae1e4 (patch)
tree830f827650f404841404c95d8b01935510607157
parent47673272c46cd73c03b067e81ddf0d952a874040 (diff)
downloadguix-be398aa2b4ed24e73cb2d6865a2040bb12eae1e4.tar.gz
gnu: git-annex: Drop Haskell documentation.
* gnu/packages/haskell-apps.scm (git-annex)[arguments]: Disable #:haddock?.
-rw-r--r--gnu/packages/haskell-apps.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index ad71713f92..12a7985116 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -306,6 +306,7 @@ to @code{cabal repl}).")
     (arguments
      `(#:configure-flags
        '("--flags=-Android -Webapp")
+       #:haddock? #f
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-shell-for-tests
@@ -386,17 +387,7 @@ to @code{cabal repl}).")
                (symlink (string-append bin "/git-annex")
                         (string-append bin "/git-annex-shell"))
                (symlink (string-append bin "/git-annex")
-                        (string-append bin "/git-remote-tor-annex")))))
-         (add-after 'install 'touch-static-output
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; The Haskell build system adds a "static" output by
-             ;; default, and there is no way to override this until
-             ;; <https://issues.guix.gnu.org/41569> is fixed.  Without
-             ;; this phase, the daemon complains because we do not
-             ;; create the "static" output.
-             (with-output-to-file (assoc-ref outputs "static")
-               (lambda ()
-                 (display "static output not used\n"))))))))
+                        (string-append bin "/git-remote-tor-annex"))))))))
     (inputs
      (list curl
            ghc-aeson