summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-14 22:16:01 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:22 -0400
commitc35c2a5a93595ca130c8c0e29021d6f3c7dea6ae (patch)
treecd371d12b9486f32bd22d0caa38dcaac9563c2aa
parentc4eae0cd631623f0c5a570aab9b5278460eabf6d (diff)
downloadguix-c35c2a5a93595ca130c8c0e29021d6f3c7dea6ae.tar.gz
gnu: rust-markup5ever-0.10: Update to 0.10.1.
* gnu/packages/crates-io.scm (rust-markup5ever-0.10): Update to 0.10.1.
[cargo-inputs]: Remove rust-serde-1, rust-serde-derive-1,
rust-serde-json-1. Sort alphabetically.
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6cda74be40..c62e465e8f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32355,7 +32355,7 @@ algorithms.  It supports CBC block cipher mode, PKCS5 padding and 64, 128,
 (define-public rust-markup5ever-0.10
   (package
     (name "rust-markup5ever")
-    (version "0.10.0")
+    (version "0.10.1")
     (source
       (origin
         (method url-fetch)
@@ -32364,19 +32364,16 @@ algorithms.  It supports CBC block cipher mode, PKCS5 padding and 64, 128,
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "1aqxl1lsc8s6ycsw5ibwynadnb9qpiab4ggwgdq9pjlnjdk8vqxa"))))
+          "1zf8iq2czd6kz99fjs3pgf5c17lfz75ds31khkfiqbc50gxl0kx2"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-log" ,rust-log-0.4)
         ("rust-phf" ,rust-phf-0.8)
-        ("rust-string-cache" ,rust-string-cache-0.8)
-        ("rust-tendril" ,rust-tendril-0.4)
         ("rust-phf-codegen" ,rust-phf-codegen-0.8)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-derive" ,rust-serde-derive-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-string-cache-codegen" ,rust-string-cache-codegen-0.5))))
+        ("rust-string-cache" ,rust-string-cache-0.8)
+        ("rust-string-cache-codegen" ,rust-string-cache-codegen-0.5)
+        ("rust-tendril" ,rust-tendril-0.4))))
     (home-page "https://github.com/servo/html5ever")
     (synopsis "Common code for xml5ever and html5ever")
     (description