summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 06:20:06 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commitc71f599cff9e6dd719b7c43940d0a0fddb9a5c22 (patch)
tree786017468a2d3748944f004db46bae289d6e37cd
parentebd845c697799f0c3560fffe93297455ba2f7149 (diff)
downloadguix-c71f599cff9e6dd719b7c43940d0a0fddb9a5c22.tar.gz
gnu: Add kactivitymanagerd.
* gnu/packages/kde-plasma.scm (kactivitymanagerd): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/kde-plasma.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index cd95f03e9b..27eaf735c5 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -32,6 +32,7 @@
   #:use-module (guix build-system qt)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages bash)
+  #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
@@ -116,6 +117,36 @@ Breeze is the default theme for the KDE Plasma desktop.")
     (license (list license:bsd-3                  ;cmake/FindSass.cmake
                    license:lgpl2.1+))))           ;<all other files>
 
+(define-public kactivitymanagerd
+  (package
+    (name "kactivitymanagerd")
+    (version "5.25.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/"
+                                  version "/" name "-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0hsllhqi46n25sr27crnad053ghk3hni2w496g6d2qfmi20l3g4n"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list boost
+                  kconfig
+                  kcoreaddons
+                  kwindowsystem
+                  kglobalaccel
+                  kio
+                  kxmlgui
+                  kdbusaddons
+                  ki18n
+                  kcrash))
+    (synopsis "System service to manage user's activities")
+    (description "This package provides components for managing the KDE Activity
+concept.")
+    (home-page "https://invent.kde.org/plasma/kactivitymanagerd")
+    (license (list license:gpl2 license:gpl3))))
+
 (define-public kdecoration
   (package
     (name "kdecoration")