summary refs log tree commit diff
diff options
context:
space:
mode:
authorMatthieu Lemerre <racin@free.fr>2023-04-18 14:28:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-18 15:18:59 +0200
commitcfc1209a8017eba2ca6c3ef03e06a637199ba269 (patch)
treee093b0c4d5d0411d9665abbc56b435dd1fdbdc6e
parent34ac0a1948881523050c3c2a178679ccb6567c3f (diff)
downloadguix-cfc1209a8017eba2ca6c3ef03e06a637199ba269.tar.gz
gnu: Add texlive-totpages.
* gnu/packages/tex.scm (texlive-totpages): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 919bb8cddd..c8f7923552 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12714,6 +12714,48 @@ changed, the recorded value will usually be the maximum value.")
 
 (define-deprecated-package texlive-latex-totcount texlive-totcount)
 
+(define-public texlive-totpages
+  (let ((template (simple-texlive-package
+                   "texlive-totpages"
+                   (list "doc/latex/totpages/"
+                         "source/latex/totpages/"
+                         "tex/latex/totpages/")
+                   (base32
+                    "1mmya2fqdskyavw3hvdiygfyp9cll7bl4lpi7pl2jf9s7ds49j5a"))))
+    (package
+      (inherit template)
+      (outputs '("out" "doc"))
+      (build-system texlive-build-system)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t) "latex/totpages")
+         ((#:tex-format _ #t) "latex")
+         ((#:build-targets _ '()) '(list "totpages.ins"))
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _ (chdir "source/latex/totpages/")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (source (string-append #$output
+                                               "/share/texmf-dist/source"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (copy-recursively (string-append origin "/source") source)
+                    (copy-recursively (string-append origin "/doc") doc))))))))
+      (native-inputs
+       (list (texlive-updmap.cfg)))
+      (propagated-inputs
+       (list texlive-everyshi texlive-latex-graphics))
+      (home-page "https://ctan.org/pkg/totpages")
+      (synopsis "Count pages in a document, and report last page number")
+      (description
+       "The package counts the actual pages in the document (as opposed to
+reporting the number of the last page, as does @code{lastpage}).  The counter
+itself may be shipped out to the DVI file.")
+      (license license:lppl))))
+
 (define-public texlive-xetex
   (package
     (inherit (simple-texlive-package