summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-27 22:13:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-27 22:15:25 +0100
commitf127bce3ecf4964d0733537b32266f93d816b6b5 (patch)
tree4b2ee2e6fe0ede6dd8b9fa854b52b29882c92d5e
parentc6bf89cff07802f5ebc7f1b1deb2e390641ec1b6 (diff)
downloadguix-f127bce3ecf4964d0733537b32266f93d816b6b5.tar.gz
gnu: pigx-chipseq: Fix Python module capture.
The build system expects all Python modules to be on PYTHONPATH.

* gnu/packages/bioinformatics.scm (pigx-chipseq)[arguments]: Set PYTHONPATH
variable in new build phase.
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e501c84265..9e7191dad8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10972,7 +10972,10 @@ expression report comparing samples in an easily configurable manner.")
        (modify-phases %standard-phases
          (add-before 'bootstrap 'autoreconf
            (lambda _
-             (invoke "autoreconf" "-vif"))))))
+             (invoke "autoreconf" "-vif")))
+         (add-before 'configure 'set-PYTHONPATH
+           (lambda _
+             (setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))
     (inputs
      (list grep
            coreutils