summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-09 22:21:47 +0100
committerMarius Bakke <marius@gnu.org>2023-01-10 00:14:43 +0100
commitf29a17c84b305068ab8593cff00570d728e49496 (patch)
treef11c83e3ba485210f2ccd0aa41155fd21f99899d
parent5e36d4381fc4d82059c4f657aae7441a141beaf6 (diff)
downloadguix-f29a17c84b305068ab8593cff00570d728e49496.tar.gz
gnu: lib3mf: Remove bundled software.
* gnu/packages/engineering.scm (lib3mf)[source](snippet): Delete bundled
copies of libzip and zlib.  Adjust header inclusions.
-rw-r--r--gnu/packages/engineering.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 627be59fcd..c9fe587170 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2305,7 +2305,25 @@ engineers for reverse engineers.")
       (snippet
        '(begin
           ;; Delete pre-compiled ACT.
-          (delete-file-recursively "AutomaticComponentToolkit/bin")))))
+          (delete-file-recursively "AutomaticComponentToolkit/bin")
+
+          ;; Remove bundled software.  Preserve cpp-base64 as it has been
+          ;; modified and cannot easily be unbundled.
+          (for-each delete-file-recursively
+                    '("Include/Libraries/libzip"
+                      "Include/Libraries/zlib"
+                      "Source/Libraries/libzip"
+                      "Source/Libraries/zlib"))
+
+          ;; Adjust header includes such that system headers are found.
+          (substitute* '("Include/Common/OPC/NMR_OpcPackageReader.h"
+                         "Include/Common/Platform/NMR_ImportStream_ZIP.h"
+                         "Include/Common/Platform/NMR_ExportStream_ZIP.h"
+                         "Include/Common/Platform/NMR_ImportStream_Compressed.h"
+                         "Include/Common/Platform/NMR_ExportStream_Compressed.h"
+                         "Source/Common/Platform/NMR_PortableZIPWriterEntry.cpp")
+            (("Libraries/libzip/") "")
+            (("Libraries/zlib/") ""))))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DUSE_INCLUDED_ZLIB=0"