summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-30 18:29:10 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-30 18:29:10 +0200
commit094aaa1a1e81b6c5461c1a2aa8ccd9019faa97ec (patch)
tree1811b5f48196eed1fc268c4a22f2d7e06d3d109a
parent81824af6a4b30368ed497686976c26f742bc6c8a (diff)
downloadguix-094aaa1a1e81b6c5461c1a2aa8ccd9019faa97ec.tar.gz
gnu: gexiv2: Skip failing test on 32-bit platforms.
* gnu/packages/gnome.scm (gexiv2)[arguments]: New field.
-rw-r--r--gnu/packages/gnome.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f19b1836d3..a9e7c20105 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4629,6 +4629,14 @@ classes for commonly used data structures.")
                (base32
                 "1qbcwq89g4r67k1dj4laqj441pj4195c8hzhxn8vc6mmg8adg6kx"))))
     (build-system meson-build-system)
+    (arguments
+     ;; On 32-bit platforms, the test fails with a rounding error:
+     ;; <https://bugzilla.gnome.org/show_bug.cgi?id=775249>.  Just skip it for
+     ;; now.
+     (if (and (not (%current-target-system))
+              (member (%current-system) '("i686-linux" "armhf-linux")))
+         '(#:tests? #f)
+         '()))
     (native-inputs
      `(("glib" ,glib "bin")
        ("pkg-config" ,pkg-config)))