summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-13 22:56:26 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-14 20:45:33 +0200
commit104be3d5e3d3cae996e49c4da237339e51f5ff33 (patch)
treeecc3b2f6fdade0ca78ff9305608a03780b97310b
parent52f82c1af046a1cdb7f2c7f676ae6c80c5baa502 (diff)
downloadguix-104be3d5e3d3cae996e49c4da237339e51f5ff33.tar.gz
gnu: Add folders.
* gnu/packages/esolangs.scm (folders): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/esolangs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 81906dac15..0651dda1b0 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
 ;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,6 +30,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -99,6 +101,24 @@ whenever possible to the extent that the above points are not compromized.
       (home-page "http://lolcode.org/")
       (license license:gpl3+))))
 
+(define-public folders
+  (package
+    (name "folders")
+    (version "0.0.8")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Folders" version))
+        (sha256
+          (base32 "0qh80qx7sjx0zii1hf8fm853d9rcg4rginm6v4gpp0hgn2a4q4gh"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/SinaKhalili/Folders.py")
+    (synopsis "Structural programming language")
+    (description "Folders is a programming language, in which programs
+are encoded as (nested) directories.  Note that the switches you pass to
+@command{du} may affect your score when code golfing.")
+    (license license:expat)))
+
 (define-public shakespeare-spl
   (package
     (name "shakespeare-spl")