summary refs log tree commit diff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-04-02 18:55:08 +0100
committerLudovic Courtès <ludo@gnu.org>2023-04-06 18:34:14 +0200
commit11e671c81678fb7901d19a4e932d9084585e50d2 (patch)
tree35808cc093d25d1c8173985f4fc30920d04f02fe
parent452b2ec593405a87661362a0ff2378470d22d3de (diff)
downloadguix-11e671c81678fb7901d19a4e932d9084585e50d2.tar.gz
gnu: libexif: Update to 0.6.24. [fixes CVE-2020-0198, CVE-2020-0452]
* gnu/packages/photo.scm (libexif): Update to 0.6.24.
[source]: Switch to git checkout.
[native-inputs]: Add autoconf, automake, gettext-minimal and libtool.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/photo.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 80fc963363..8df1034487 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -211,18 +211,19 @@ cameras (CRW/CR2, NEF, RAF, DNG, and others).")
 (define-public libexif
   (package
     (name "libexif")
-    (version "0.6.22")
+    (version "0.6.24")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/libexif/libexif/releases"
-                    "/download/libexif-"
-                    (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
-                    "-release/libexif-" version ".tar.xz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/libexif/libexif.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0mhcad5zab7fsn120rd585h8ncwkq904nzzrq8vcd72hzk4g2j2h"))))
+                "0zi5vvb0khlzc6xyfayk6mjx5lgkrj8r7s8lfv4j7wkcgndjga0j"))))
     (build-system gnu-build-system)
+    (native-inputs
+     (list autoconf automake gettext-minimal libtool))
     (home-page "https://libexif.github.io/")
     (synopsis "Read and manipulate EXIF data in digital photographs")
     (description