summary refs log tree commit diff
diff options
context:
space:
mode:
authorGarek Dyszel <garekdyszel@disroot.org>2022-09-07 14:34:39 -0400
committerJulien Lepiller <julien@lepiller.eu>2022-09-24 20:24:50 +0200
commit13c1ed6a198985141f13fb1899bb5fc05f408915 (patch)
tree3109f55741c277dbbbd90ec0435246cdd6f88a03
parent142cccef63651a50348c611790ebe22ec343676e (diff)
downloadguix-13c1ed6a198985141f13fb1899bb5fc05f408915.tar.gz
gnu: Add python-editables.
* gnu/packages/python-build.scm (python-editables): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/python-build.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index e7023aca0c..9d9b07f769 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2018, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -474,3 +475,25 @@ system, then @code{flit_core} to build the package.")
 @dfn{software configuration management} (SCM) metadata instead of declaring
 them as the version argument or in a SCM managed file.")
     (license license:expat)))
+
+(define-public python-editables
+  (package
+    (name "python-editables")
+    (version "0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pfmoore/editables")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gbfkgzmrmbd4ycshm09fr2wd4f1n9gq7s567jgkavhfkn7s2pn1"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/pfmoore/editables")
+    (synopsis "Editable installations")
+    (description "This library supports the building of wheels which, when
+installed, will expose packages in a local directory on @code{sys.path} in
+``editable mode''.  In other words, changes to the package source will be
+reflected in the package visible to Python, without needing a reinstall.")
+    (license license:expat)))