summary refs log tree commit diff
diff options
context:
space:
mode:
authorOtt Joon <oj@vern.cc>2023-01-22 00:33:13 +0200
committerAndrew Tropin <andrew@trop.in>2023-02-01 12:52:53 +0400
commit14323edcc37d9efaae2491cf5f57ea0621412d7e (patch)
tree5d6bc1d6aad9a9b0fd94b8dd482707509b0ecbdf
parentaa2c59359e11e47342083e530d399c5dbe54a7c7 (diff)
downloadguix-14323edcc37d9efaae2491cf5f57ea0621412d7e.tar.gz
gnu: Add obs-vkcapture.
* gnu/packages/video.scm (obs-vkcapture): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/video.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b86d305a5f..54cf7be9a7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -63,6 +63,7 @@
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
 ;;; Copyright © 2022 Andy Tai <atai@atai.org>
+;;; Copyright © 2023 Ott Joon <oj@vern.cc>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3576,6 +3577,38 @@ programs on your current machine or on other machines.")
 Wayland compositors.")
     (license license:gpl3+)))
 
+(define-public obs-vkcapture
+  (package
+    (name "obs-vkcapture")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nowrep/obs-vkcapture")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "18v15bfzm31qkpwipvbqgzak4z6f2hhq6mnz2bvhwnv57whirln6"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ;no tests
+    (native-inputs (list pkg-config))
+    (inputs (list mesa
+                  obs
+                  libx11
+                  libxcb
+                  vulkan-headers
+                  vulkan-loader
+                  wayland))
+    (home-page "https://github.com/nowrep/obs-vkcapture")
+    (synopsis "OBS plugin for Vulkan/OpenGL game capture on Linux")
+    (description
+     "This OBS plugin lets you record an OpenGL or Vulkan
+game by adding the Game Capture source to your scene and starting an
+application with @code{obs-gamecapture}.")
+    (license license:gpl2)))
+
 (define-public libvdpau
   (package
     (name "libvdpau")