summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-19 08:26:32 +0100
committerMarius Bakke <marius@gnu.org>2022-11-19 22:07:33 +0100
commit273988e94c6f87f554e552c11b09cab65897e081 (patch)
treebd06d4b0cf476513f9ffe8a373ce090f94e12379
parentb654726c4547364b035a7389ab25ee98c84b9308 (diff)
downloadguix-273988e94c6f87f554e552c11b09cab65897e081.tar.gz
gnu: python-check-manifest: Use the 'fixed' git for tests.
* gnu/packages/python-xyz.scm (python-check-manifest)[native-inputs]: Change
from GIT to GIT-MINIMAL/FIXED.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f91662713c..0daeb3c0fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25569,8 +25569,6 @@ also be usable with other GSSAPI mechanisms.")
          (base32
           "0lk45ifdv2cpkl6ayfyix7jwmnxa1rha7xvb0ih5999k115wzqs4"))))
     (build-system python-build-system)
-    (native-inputs
-     (list python-mock git))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -25582,6 +25580,8 @@ also be usable with other GSSAPI mechanisms.")
              (setenv "HOME" "/tmp")
              (invoke "git" "config" "--global"
                      "protocol.file.allow" "always"))))))
+    (native-inputs
+     (list python-mock git-minimal/fixed))
     (home-page "https://github.com/mgedmin/check-manifest")
     (synopsis "Check MANIFEST.in in a Python source package for completeness")
     (description "Python package can include a MANIFEST.in file to help with