summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-17 22:07:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:44 -0400
commit2a34881356ae60ea2426a4008bbae8a24f9a3468 (patch)
tree9b8c4ac24cade6ea1ac9f5694374ce46f8d6199f
parent208cf6916e7a9708c1ae6cc49c129719ca0089a7 (diff)
downloadguix-2a34881356ae60ea2426a4008bbae8a24f9a3468.tar.gz
gnu: ruby-shoulda: Honor #:tests?.
* gnu/packages/ruby.scm (ruby-shoulda)
[arguments]: Honor #:tests? in check phase.
-rw-r--r--gnu/packages/ruby.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 24b5546ecf..f02ed79588 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10152,9 +10152,11 @@ more complex, and error-prone.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           ;; Don't run tests to avoid circular dependence with rails.  Instead
-           ;; just import the library to test.
-           (lambda _ (invoke "ruby" "-Ilib" "-r" "shoulda")))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Don't run tests to avoid circular dependence with rails.
+               ;; Instead just import the library to test.
+               (invoke "ruby" "-Ilib" "-r" "shoulda"))))
          (add-after 'extract-gemspec 'relax-requirements
            (lambda _
              (substitute* "shoulda.gemspec"