summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-09-27 00:19:17 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:08 +0100
commit2c65a197fc22edf83cc095e5fd766e3234fdba0c (patch)
treec23aeb21b860ab631df4a56ea2def1dba1d90fe8
parentde3829816d7a49dfa06b6fb080446f1d0be6f657 (diff)
downloadguix-2c65a197fc22edf83cc095e5fd766e3234fdba0c.tar.gz
gnu: Add python-doxypypy.
* gnu/packages/python-xyz.scm (python-doxypypy): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f736f05ac..eaad292a7f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3092,6 +3092,24 @@ other Python program.")
      "This package provides a Doxygen input filter for QML files.")
     (license license:bsd-3)))
 
+(define-public python-doxypypy
+  (package
+    (name "python-doxypypy")
+    (version "0.8.8.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "doxypypy" version))
+              (sha256
+               (base32
+                "06z0vbh975g42z5szbfvn9i3bif3xwr5pncqd4fvjzjkbi2p2xb2"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))          ;no test suite
+    (home-page "https://github.com/Feneric/doxypypy")
+    (synopsis "Doxygen filter for Python")
+    (description
+     "This package provides a Doxygen filter for Python.")
+    (license license:gpl2+)))
+
 (define-public python-empy
   (package
     (name "python-empy")