summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-03-22 12:45:48 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-22 12:59:32 +0100
commit326249bab8e525b8c71f862fb1f2569d703a3e84 (patch)
tree15507feb35a84c787fdaa4632d907c9c7121cc05
parent54262c543553a023c8835d706c2c1063cf20c079 (diff)
downloadguix-326249bab8e525b8c71f862fb1f2569d703a3e84.tar.gz
gnu: rustc: End resultless phases in #t.
* gnu/packages/rust.scm (rustc): End resultless phases in #t.
-rw-r--r--gnu/packages/rust.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 2dedef8373..b72a206e6a 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -229,11 +229,13 @@ rustc-bootstrap and cargo-bootstrap packages.")
                (("/usr/bin/env") (which "env")))
              ;; Avoid curl as a build dependency.
              (substitute* "configure"
-               (("probe_need CFG_CURL curl") ""))))
+               (("probe_need CFG_CURL curl") ""))
+             #t))
          (add-after 'unpack 'set-env
            (lambda _
              (setenv "SHELL" (which "sh"))
-             (setenv "CONFIG_SHELL" (which "sh"))))
+             (setenv "CONFIG_SHELL" (which "sh"))
+             #t))
          (add-after 'unpack 'patch-tests
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "src/tools/tidy/src/main.rs"
@@ -275,7 +277,8 @@ rustc-bootstrap and cargo-bootstrap packages.")
                ;; Let gcc find ld and libc startup files.
                (wrap-program (string-append out "/bin/rustc")
                  `("PATH" ":" prefix (,(string-append ld-wrapper "/bin")))
-                 `("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))))))))
+                 `("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))
+               #t))))))
     ;; rustc invokes gcc, so we need to set its search paths accordingly.
     (native-search-paths (package-native-search-paths gcc))
     (synopsis "Compiler for the Rust progamming language")