summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-25 22:50:12 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-25 22:52:57 +0800
commit347175a27c4e37aa2f8acb8024cadb5d28b11cac (patch)
treee87a34a055925d116dede781f718c40f5a403c40
parentb49504fd8c2f61fe5aae27598e5a475de1f9494b (diff)
downloadguix-347175a27c4e37aa2f8acb8024cadb5d28b11cac.tar.gz
gnu: Add python-flexmock and python2-flexmock.
* gnu/packages/python.scm (python-flexmock, python2-flexmock): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 80715133c3..46179b51db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9594,3 +9594,26 @@ YAML-serialized data.")
 (define-public python2-pyaml
   (package-with-python2 python-pyaml))
 
+(define-public python-flexmock
+  (package
+    (name "python-flexmock")
+    (version "0.10.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "flexmock" version))
+              (sha256
+               (base32
+                "0arc6njvs6i9v9hgvzk5m50296g7zy5m9d7pyb43vdsdgxrci5gy"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://flexmock.readthedocs.org")
+    (synopsis "Testing library for Python")
+    (description
+     "flexmock is a testing library for Python that makes it easy to create
+mocks, stubs and fakes.")
+    (license bsd-3)))
+
+(define-public python2-flexmock
+  (package-with-python2 python-flexmock))
+