summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <ericbavier@gmail.com>2014-02-07 17:04:58 -0600
committerLudovic Courtès <ludo@gnu.org>2014-02-08 18:00:25 +0100
commit350b9b9933bdfd46efd3e9dee6f1dd1ec5889818 (patch)
tree563cc1ab64a9b83f922c18b86631b25e429fc8f2
parente30835e24797e7e2633d608cfa1f6c8f591a214c (diff)
downloadguix-350b9b9933bdfd46efd3e9dee6f1dd1ec5889818.tar.gz
gnu: moe: New module
* gnu/packages/moe.scm: New file
* gnu-system.am (GNU_SYSTEM_MODULES): Add moe.scm

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/moe.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index eb1e0d06dc..1ffeee5084 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -141,6 +141,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/make-bootstrap.scm		\
   gnu/packages/maths.scm			\
   gnu/packages/mit-krb5.scm			\
+  gnu/packages/moe.scm				\
   gnu/packages/mp3.scm				\
   gnu/packages/multiprecision.scm		\
   gnu/packages/mtools.scm			\
diff --git a/gnu/packages/moe.scm b/gnu/packages/moe.scm
new file mode 100644
index 0000000000..0dead5fe0c
--- /dev/null
+++ b/gnu/packages/moe.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages moe)
+  #:use-module (guix licenses)
+  #:use-module (gnu packages ncurses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public moe
+  (package
+    (name "moe")
+    (version "1.5")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/moe/moe-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "0hqag8022x68jmii1v6n7jb4fhp9icjkapgcpd2j3p9nzc8xch7s"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (home-page "https://www.gnu.org/software/moe/moe.html")
+    (synopsis "Modeless, multiple-buffer, user-friendly 8-bit text editor")
+    (description
+     "GNU Moe is a powerful-but-simple-to-use text editor.  It works in a
+modeless manner, and features an intuitive set of key-bindings that
+assign a degree of severity to each key; for example, key
+combinations with the Alt key are for harmless commands like cursor
+movements while combinations with the Control key are for commands
+that will modify the text.  Moe features multiple windows, unlimited
+undo/redo, unlimited line length, global search and replace, and
+more.")
+    (license gpl3+)))