summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:19 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:57 +0000
commit3e15ad0329a9036d34dd147414f430be5d7db6ab (patch)
treee1bd0cd4d3e61243e11aa7499c25de62e5b40063
parent7fbe38d7bf90dacc90ec514ddb3a0274fa880d40 (diff)
downloadguix-3e15ad0329a9036d34dd147414f430be5d7db6ab.tar.gz
gnu: Add ocaml-async-rpc-kernel.
* gnu/packages/ocaml.scm (ocaml-async-rpc-kernel): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 10655923d0..87a62805fd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8465,6 +8465,31 @@ or select, depending on availability, and manages a thread pool that blocking
 system calls run in.")
     (license license:expat)))
 
+(define-public ocaml-async-rpc-kernel
+  (package
+    (name "ocaml-async-rpc-kernel")
+    (version "0.15.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/janestreet/async_rpc_kernel")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1b5rp5yam03ir4f1sixpzjg1zdqmkb7lvnaa82kac4fzk80gfrfr"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-async-kernel ocaml-core ocaml-ppx-jane
+                             ocaml-protocol-version-header))
+    (properties `((upstream-name . "async_rpc_kernel")))
+    (home-page "https://github.com/janestreet/async_rpc_kernel")
+    (synopsis "Platform-independent core of Async RPC library")
+    (description
+     "Library for building RPC-style protocols.  This library is the portable
+part of the Unix-oriented Async_rpc library, and is actively used in
+JavaScript.")
+    (license license:expat)))
+
 (define-public ocaml-textutils-kernel
   (package
     (name "ocaml-textutils-kernel")