summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-17 16:10:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-30 12:35:55 +0300
commit427439526ccca3bbf8be74205e3245f91aa13cdc (patch)
treeddf20ec853a56a6a983b90d05e4523ac458220cd
parent7e1d6bb247c617120e76ea922192f84830594386 (diff)
downloadguix-427439526ccca3bbf8be74205e3245f91aa13cdc.tar.gz
gnu: sysbench: Build with mariadb.
* gnu/packages/benchmark.scm (sysbench)[arguments]: Remove mysql flag.
[inputs]: Remove mysql. Add mariadb:dev.
-rw-r--r--gnu/packages/benchmark.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 733078d875..8840100d68 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -612,13 +612,6 @@ its features are:
     (arguments
      (list
       #:configure-flags #~(list "--with-pgsql"
-                                ;; Explicitly specify the library directory of
-                                ;; MySQL, otherwise `mysql_config` gets
-                                ;; consulted and adds unnecessary link
-                                ;; directives.
-                                (string-append "--with-mysql-libs="
-                                               #$(this-package-input "mysql")
-                                               "/lib")
                                 "--with-system-luajit"
                                 "--with-system-ck"
                                 ;; If we let the build tool select the most
@@ -659,7 +652,7 @@ its features are:
                          libxslt
                          docbook-xml
                          docbook-xsl))
-    (inputs (list ck libaio luajit mysql postgresql))
+    (inputs (list ck libaio luajit (list mariadb "dev") postgresql))
     (home-page "https://github.com/akopytov/sysbench/")
     (synopsis "Scriptable database and system performance benchmark")
     (description "@command{sysbench} is a scriptable multi-threaded benchmark