summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-09-12 11:48:17 +0800
committer宋文武 <iyzsong@gmail.com>2015-09-12 11:55:45 +0800
commit42e666494d4594eb8aa345f84e55b0b9e5297f6e (patch)
tree8526718e8a15cbb3939c4d69310dc4e6ccf39715
parent895067ff495a35768e1ba39e969eff3495b8cbc4 (diff)
downloadguix-42e666494d4594eb8aa345f84e55b0b9e5297f6e.tar.gz
gnu: sqlite: Update to 3.8.11.1.
* gnu/packages/databases.scm (sqlite): Update to 3.8.11.1.
  [source](uri): Add 'http://distfiles.gentoo.org'.
-rw-r--r--gnu/packages/databases.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d7e3fd91fb..98be700b80 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -311,7 +311,7 @@ types are supported, as is encryption.")
 (define-public sqlite
   (package
    (name "sqlite")
-   (version "3.8.10.2")
+   (version "3.8.11.1")
    (source (origin
             (method url-fetch)
             ;; TODO: Download from sqlite.org once this bug :
@@ -326,12 +326,16 @@ types are supported, as is encryption.")
                                             (map (cut string-pad <> 2 #\0)
                                                  other-digits))
                                            6 #\0))))))
-                   (string-append
-                    "mirror://sourceforge/sqlite.mirror/SQLite%20" version
-                    "/sqlite-autoconf-" numeric-version ".tar.gz")))
+                   (list
+                    (string-append
+                     "http://distfiles.gentoo.org/distfiles/"
+                     "/sqlite-autoconf-" numeric-version ".tar.gz")
+                    (string-append
+                     "mirror://sourceforge/sqlite.mirror/SQLite%20" version
+                     "/sqlite-autoconf-" numeric-version ".tar.gz"))))
             (sha256
              (base32
-              "09nnaqx50gl1vmfvdipirizr61q3s0ywlql50f9kr1bx9rdfb0l3"))))
+              "1dnkl4qr1dgaprbyf3jddfiynkhxnin86qabni47wjlc0fnb16gv"))))
    (build-system gnu-build-system)
    (inputs `(("readline" ,readline)))
    (arguments