summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-05 15:30:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-05 15:43:09 +0200
commit45ace7bc94a768264b0c59635105cdc1004a17fe (patch)
tree45c1bc1f8afeacd8a235405c28ce4d6fe8a08869
parentd11a432adffe9308eafec6b77cddd3145029109e (diff)
downloadguix-45ace7bc94a768264b0c59635105cdc1004a17fe.tar.gz
gnu: Add r-poorman.
* gnu/packages/cran.scm (r-poorman): New variable.
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 094dd4e449..d7491e28ea 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1448,6 +1448,26 @@ qualitative palettes with many (20-30 or more) colors.  See Coombes and
 colleagues (2019) @url{https://doi:10.18637/jss.v090.c01}.")
     (license license:asl2.0)))
 
+(define-public r-poorman
+  (package
+    (name "r-poorman")
+    (version "0.2.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "poorman" version))
+              (sha256
+               (base32
+                "05h7rjgri0b5a1jd0388p7lqvvg0y8z6g42f9bxc80jg1z730axr"))))
+    (properties `((upstream-name . "poorman")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://nathaneastwood.github.io/poorman/")
+    (synopsis "Dependency-free recreation of dplyr")
+    (description
+     "This package provides a replication of key functionality from
+@code{dplyr} and the wider @code{tidyverse} using only @code{base}.")
+    (license license:expat)))
+
 (define-public r-ecp
   (package
     (name "r-ecp")