summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 14:01:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 14:01:56 +0100
commit469fb438918df593f6c38b18e78532a25be2ccef (patch)
tree15217bc28fe91a4a2ff0ffd612100889cd3ac919
parent7cd4ff2f0cb950744074af56711bd8a83c08fda1 (diff)
downloadguix-469fb438918df593f6c38b18e78532a25be2ccef.tar.gz
gnu: r-sparql: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-sparql): Move from here...
* gnu/packages/cran.scm (r-sparql): ...to here.
-rw-r--r--gnu/packages/bioinformatics.scm23
-rw-r--r--gnu/packages/cran.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a615a9c5da..7d3b34d1a9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7014,29 +7014,6 @@ annotation infrastructure.")
      "This package provides a pipeline for the analysis of GRO-seq data.")
     (license license:gpl3+)))
 
-(define-public r-sparql
-  (package
-  (name "r-sparql")
-  (version "1.16")
-  (source (origin
-           (method url-fetch)
-           (uri (cran-uri "SPARQL" version))
-           (sha256
-            (base32
-             "0gak1q06yyhdmcxb2n3v0h9gr1vqd0viqji52wpw211qp6r6dcrc"))))
-  (properties `((upstream-name . "SPARQL")))
-  (build-system r-build-system)
-  (propagated-inputs
-   `(("r-rcurl" ,r-rcurl)
-     ("r-xml" ,r-xml)))
-  (home-page "https://cran.r-project.org/web/packages/SPARQL")
-  (synopsis "SPARQL client for R")
-  (description "This package provides an interface to use SPARQL to pose
-SELECT or UPDATE queries to an end-point.")
-  ;; The only license indication is found in the DESCRIPTION file,
-  ;; which states GPL-3.  So we cannot assume GPLv3+.
-  (license license:gpl3)))
-
 (define-public vsearch
   (package
     (name "vsearch")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb97f72353..d4564f4f49 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12646,3 +12646,26 @@ exact test for Hardy-Weinberg equilibrium.")
 tests for extended marker haplotypes, as in Clayton, D. and Jones, H. (1999)
 \"Transmission/disequilibrium tests for extended marker haplotypes\".")
     (license license:artistic2.0)))
+
+(define-public r-sparql
+  (package
+    (name "r-sparql")
+    (version "1.16")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "SPARQL" version))
+              (sha256
+               (base32
+                "0gak1q06yyhdmcxb2n3v0h9gr1vqd0viqji52wpw211qp6r6dcrc"))))
+    (properties `((upstream-name . "SPARQL")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcurl" ,r-rcurl)
+       ("r-xml" ,r-xml)))
+    (home-page "https://cran.r-project.org/web/packages/SPARQL")
+    (synopsis "SPARQL client for R")
+    (description "This package provides an interface to use SPARQL to pose
+SELECT or UPDATE queries to an end-point.")
+    ;; The only license indication is found in the DESCRIPTION file,
+    ;; which states GPL-3.  So we cannot assume GPLv3+.
+    (license license:gpl3)))