summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-04 13:03:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-04 14:24:00 +0200
commit48a61e45ac98df8299cd0c2f303fd0f5476ef7ba (patch)
tree4f9c4446b0cb567d2ef0a20cbcdaead98262c395
parent14516b6004b491cfa6c968e72f934b052d5ca6b0 (diff)
downloadguix-48a61e45ac98df8299cd0c2f303fd0f5476ef7ba.tar.gz
gnu: font-jetbrains-mono: Simplify licence installation.
* gnu/packages/fonts.scm (font-jetbrains-mono)[arguments]: Don't replace
the ‘install-license-files’ phase.  Help it.
-rw-r--r--gnu/packages/fonts.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 441014994d..f39c529beb 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1749,12 +1749,11 @@ This package provides the TrueType fonts.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (replace 'install-license-files
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (doc (string-append out "/share/doc/" ,name "-" ,version)))
-               (install-file "../LICENSE" doc)
-               #t))))))
+         (add-before 'install-license-files 'change-directory-to-archive-root
+           ;; Find the LICENSE file outside of the default subdirectory.
+           (lambda _
+             (chdir "..")
+             #t)))))
     (home-page "https://www.jetbrains.com/lp/mono/")
     (synopsis "Mono typeface for developers")
     (description