summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 21:04:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:26 +0300
commit4b6de1938d7336ae4c30125c89cd0ea5dc80eee1 (patch)
tree07696eccb64460cfbb63654f96e0c366ddaf7693
parent1636de18d6cadb254c97385dd9d4b8f824379baf (diff)
downloadguix-4b6de1938d7336ae4c30125c89cd0ea5dc80eee1.tar.gz
gnu: Add rust-pyproject-toml-0.6.
* gnu/packages/crates-io.scm (rust-pyproject-toml-0.6): New variable.
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1f3508ecd5..d2c4d5d16f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49623,6 +49623,30 @@ Python code from a Rust binary is also supported.")
         ("rust-serde-json" ,rust-serde-json-1)
         ("rust-trybuild" ,rust-trybuild-1))))))
 
+(define-public rust-pyproject-toml-0.6
+  (package
+    (name "rust-pyproject-toml")
+    (version "0.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pyproject-toml" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pywp6ml15jlv9yxfjcvrs3fgd3xnq8fc6a2wcbw9q9iknmgwygf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-indexmap" ,rust-indexmap-1)
+        ("rust-pep440-rs" ,rust-pep440-rs-0.3)
+        ("rust-pep508-rs" ,rust-pep508-rs-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-toml" ,rust-toml-0.7))))
+    (home-page "https://github.com/PyO3/pyproject-toml-rs.git")
+    (synopsis "pyproject.toml parser in Rust")
+    (description "This package provides a pyproject.toml parser in Rust.")
+    (license license:expat)))
+
 (define-public rust-python3-dll-a-0.2
   (package
     (name "rust-python3-dll-a")