summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-26 10:59:05 +0200
committerAndrew Tropin <andrew@trop.in>2022-11-28 12:50:18 +0400
commit4cb299e22ec8d38174e2f05327cf88e2803d0ff0 (patch)
treead17cb7c083ef01d617047d4dd8220f79c22a4fa
parentbf7c69b0432b0367966260bacbbc0de3a464051a (diff)
downloadguix-4cb299e22ec8d38174e2f05327cf88e2803d0ff0.tar.gz
gnu: Add rust-clap-lex-0.2.
* gnu/packages/crates-io.scm (rust-clap-lex-0.2): New variable.

Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8a6e8b10c6..2da61b385e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68473,6 +68473,28 @@ character.")
       "This package provides a library to unify commandline arguments with config files and environment variables.  And make it easier for users to tell your program how to behave across the three main input sources")
     (license license:expat)))
 
+(define-public rust-clap-lex-0.2
+  (package
+    (name "rust-clap-lex")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "clap_lex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ib1a9v55ybnaws11l63az0jgz5xiy24jkdgsmyl7grcm3sz4l18"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-os-str-bytes" ,rust-os-str-bytes-6))))
+    (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
+    (synopsis "Command-line parser for Rust")
+    (description "This package provides a command-line parser for Rust.  As
+opposed to a declarative parser, @code{rust-clap-lex} processes arguments as a
+stream of tokens.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public svd2rust
   (package
     (name "svd2rust")